Ubuntu Server 15.04 : l’erreur de la fraîcheur !

Ubuntu Server 15.04 : l'erreur de la fraîcheur !Au cours de cette 2e journée de formation en sécurité informatique que je donne au Havre, j’ai présenté cet après-midi le proxy Squid sur Linux. A cette occasion, j’ai pris la 1ère distribution qui me venait sous la main, une Ubuntu Server 15.04. Mal m’en prit.

Après avoir configuré Squid sans problème particulier, nous nous sommes alors attelé à configurer SquidGuard. Or, SquidGuard refusait de fonctionner avec Squid. Aucun message dans les logs de Squid et de SquidGuard. De guerre lasse, j’ai donc décidé de regarder les numéros de version des deux logiciels : 3.3.8 pour Squid et 1.5.4 pour SquidGuard. J’ai ensuite googlelisé… pour me rendre compte que ces deux versions étaient, au dire des messages vus sur Google, incompatibles l’une avec l’autre.

Où va Linux ?

Comment est-il possible de livrer un OS Linux pour serveurs sans avoir pris le temps de vérifier que ces deux outils fonctionnent ensemble ? Je suis inquiet sur ce qui se passe dans le monde Linux. Et toute cette entropie des développeurs dans des projets inutiles – aussi sympathiques soient-ils – comme systemd, firewalld, Unity, Cinnamon, Mate ?

Addendum et happy end !

Testé ce soir-même. Disponibles sur la version Ubuntu Server 14.04.3 LTS, les paquets Squid 3.3.8 et SquidGuard 1.5.2 fonctionnent à la perfection !

Ubuntu  / Formateur Sécurité informatique Formateur Squid Formateur SquidGuard Formateur Ubuntu Server Sécurité informatique Squid SquidGuard Ubuntu Server LTS 

Commentaires

Hello,

Je ne suis pas sûr de comprendre, Squid et SquidGuard sont livrés sur l’iso c’est ça ?

Tcho !

@Cascador

Dans les dépôts !!!

Bonjour,

Je viens de perdre 1 journée complète à m’arracher les cheveux pour essayer de faire fonctionner Squid 3.3.8-6.4(64Bit) avec SquidGuard 1.5.4 (64bit) sous Ubuntu server 14.0.4.3 (64bit). Bien évidemment je n’ai pas trouvé de solution et quand je lis votre article, je comprend mieux pourquoi …
Bref à par la version de Ubuntu server, notre config semble la même et le résultat identique (impssible d’accéder à une seul site web, page blanche ou erreur), Squid fonctionne seul mais pas quand SquidGuard est lancé (je n’obtiens d’ailleurs qu’1 seul redirect sur 10 demandés…).

Dire que ça fait des années que je prenais Ubuntu server 10.4.3 (64bit), Squid 3.0.STABLE19 (64bit) et squidGuard 1.2.0-8.4(64bit) et que tout fonctionnait parfaitement mais bien sûr j’ai voulu prendre du « neuf » et paf patatra !

Demain ce sera donc un essai avec squidGuard 1.5.2 en espérant que çà fonctionne…

@Boudpapier

Vous devriez opter pour Debian ou pour CentOS ou pour openSUSE. Là, c’est du sérieux ! ;+)

Bonjour,

Petit retour, tout fonctionne entre 3.3.8-6.4(64Bit) avec SquidGuard 1.5.2 (64bit) sous Ubuntu server 14.0.4.3 (64bit) :)
Chose « amusante », si j’avais tapé « sudo aptitude install squidguard » j’aurai eu la version 1.5.2 d’office mais voilà, j’ai voulu prendre le dernier paquet dispo et l’installer manuellement et j’ai perdu 1 journée…

Pour ce qui est d’utiliser d’autres suites linux, ça fait longtemps que pense passer sous débian mais faute de temps, j’ai préféré rester sur ce que je connais, cad Ubuntu serveur.
Si j’avais su que j’allais perdre 1 journée sur ce coup là en changeant de version d’ubuntu/squid/squidguard, j’aurai été plus avancé de la perdre en passant sur une autre suite, au moins j’aurai vu quelquechose de nouveau…

En tous cas, content d’être tombé (au hasard de mes recherches) sur votre site web car j’en serai peut être encore à chercher la cause de mes problèmes…

Merci ;)

@+

@Boudpapier

J’ai du mal à comprendre ce qui vous pose problème à passer à Debian. L’existant ? Dans ce cas, effectivement, ça peut se comprendre, en effet.

Laisser un commentaire

(requis)

(requis)