JRE devient payant : je passe à OpenJDK !

Java payant : je passe à OpenJDK !A l’exception des développeurs et des particuliers, le 16 avril, Java – JRE, JSE, JDK – est devenu payant pour un usage commercial. Jusqu’à présent, il l’était seulement pour l’embarqué. Désormais, le payant s’étend aux serveurs d’application et aux clients lourds. Il n’y a donc plus grand intérêt à utiliser le Java commercial d’Oracle . Heureusement pour les développeurs, OpenJDK reste en Open Source.

J’ai donc désinstallé toutes mes JRE 32 et 64 bits. J’ai ensuite cherché un installeur de OpenJDK 32 bits pour Windows. J’ai eu un mal de chien à trouver la perle rare. J’ai finalement installé la version 12 d’OpenJDK. Et, puis, j’ai voulu tester si je parvenais à exécuter RSSOwl. Et là, ce fut le drame. Dans le fichier de log, j’ai eu droit à toute une batterie de messages :

!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.core.runtime_3.4.0.v20080512.jar/ [3] was not resolved.
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.core.runtime_3.4.0.v20080512.jar/ was not resolved.
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.equinox.common_3.4.0.v20080421-2006.jar/ [1] was not resolved.
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.equinox.common_3.4.0.v20080421-2006.jar/ was not resolved.
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.update.configurator_3.2.201.R34x_v20080819.jar/ [2] was not resolved.
!MESSAGE Bundle initial@reference:file:plugins/org.eclipse.update.configurator_3.2.201.R34x_v20080819.jar/ was not resolved.

Je suis donc passé à la version 8 d’OpenJDK : RSSOwl s’est alors parfaitement exécuté.

Développement  / Java 

Commentaires

Pas encore de commentaire.

Laisser un commentaire

(requis)

(requis)